Qpid
  1. Qpid
  2. QPID-4890

[AMQP 1.0] interllink tests hang on older versions of python

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.22
    • Fix Version/s: 0.23
    • Component/s: None
    • Labels:
      None

      Description

      These use subprocess.Popen() to start a sender reading from stdin. However the closing of stdin has no effect when running on older python e.g. 2.3 on RHEL5, which seems to be due to http://bugs.python.org/issue4112.

        Activity

        Hide
        Gordon Sim added a comment -
        Show
        Gordon Sim added a comment - Workaround added to test in http://svn.apache.org/viewvc?view=revision&revision=1486625
        Hide
        Justin Ross added a comment -
        Show
        Justin Ross added a comment - Released in Qpid 0.24, http://qpid.apache.org/releases/qpid-0.24/index.html

          People

          • Assignee:
            Gordon Sim
            Reporter:
            Gordon Sim
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development