Qpid
  1. Qpid
  2. QPID-4805

qpid-config default journal parameters override qpidd.conf

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.22
    • Fix Version/s: 0.23
    • Component/s: Python Tools
    • Labels:
      None

      Description

      From Leonid:
      """
      The user can set default journal parameters (number of files and a size of each file) in qpidd config file. These are the options 'num-jfiles' and 'jfile-size-pgs', which are properly documented. The broker is supposed to use these parameters while creating a new durable queue in case that no journal parameters were provided by the client's application.
      The problem is that qpid-config tool sends values fileCount = 8, fileSize = 24 to the broker if called without "-file-count" and "-file-size" parameters.
      Imagine the situation where a user sets some default 'num-jfiles' and 'jfile-size-pgs' values in qpidd config file and then creates a durable queue using qpid-config tool: 'qpid-config add queue test --durable'. The resulting queue's journal will have parameters fileCount = 8, fileSize = 24, which will differ from the ones set by the user in config file.
      """

        Activity

        Justin Ross added a comment -

        http://svn.apache.org/viewvc?view=revision&revision=1478309

        Thanks to Ernie Allen for providing the patch.

        Justin Ross added a comment -

          People

          • Assignee:
            Justin Ross
            Reporter:
            Justin Ross
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development