Qpid
  1. Qpid
  2. QPID-4701

Exception types lost in qpidmessaging when compiling with cmake and gcc 4.1.2 (e.g. RHEL5)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20, 0.22
    • Fix Version/s: 0.23
    • Component/s: C++ Client
    • Labels:
      None

      Description

      Exceptions are thrown simply as std::exception rather than the specific types defined. This appears to be a result of the visibility flag support in the version of gcc (cmake turns that on, autotools does not).

      (See also QPID-4484)

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        18d 23m 1 Gordon Sim 22/Apr/13 13:11
        Resolved Resolved Closed Closed
        139d 26m 1 Justin Ross 08/Sep/13 13:37
        Justin Ross made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Justin Ross added a comment -
        Gordon Sim made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 0.23 [ 12324273 ]
        Resolution Fixed [ 1 ]
        Gordon Sim added a comment -

        I've committed the patch for now as it fixes the build issue: http://svn.apache.org/viewvc?view=revision&revision=1464930. It can be reverted in favour of a better solution if and when one emerges.

        Gordon Sim added a comment -

        I suspect its a defect in gcc 4.1.2's support of the visibility flag. However that is speculation. The facts are that with the flag on the issue is apparent on 4.1.2, with the flag off it is not.

        Andrew Stitcher added a comment -

        I'm confused by one thing though - it would seem that if the symbol visibility was the cause of the problem it would happen in all version of gcc not just 4.1.2.

        Gordon Sim added a comment -

        Suggested change is to disable the visibility setting on the affected version of gcc: https://reviews.apache.org/r/10283/

        Gordon Sim created issue -

          People

          • Assignee:
            Gordon Sim
            Reporter:
            Gordon Sim
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development