Qpid
  1. Qpid
  2. QPID-4606

Java Performance Test and Visualisation unit test timeouts insufficient for slow CI servers

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.20
    • Fix Version/s: 0.21
    • Component/s: Java Performance Tests
    • Labels:
      None

      Description

      Java Performance Test and Visualisation unit tests sometimes fail because of timeouts. These appear to be simply caused by slow CI servers.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        58s 1 Philip Harvey 27/Feb/13 09:43
        In Progress In Progress Reviewable Reviewable
        4m 1s 1 Philip Harvey 27/Feb/13 09:47
        Reviewable Reviewable Resolved Resolved
        13d 11h 59m 1 Keith Wall 12/Mar/13 21:47
        Keith Wall made changes -
        Link This issue is a clone of QPID-4605 [ QPID-4605 ]
        Keith Wall made changes -
        Status Ready To Review [ 10006 ] Resolved [ 5 ]
        Fix Version/s 0.21 [ 12323549 ]
        Resolution Fixed [ 1 ]
        Keith Wall added a comment -

        Changes look reasonable, no comments from me.

        Philip Harvey made changes -
        Summary CLONE - Java Performance Test unit test timeouts insufficient for slow CI servers Java Performance Test and Visualisation unit test timeouts insufficient for slow CI servers
        Philip Harvey made changes -
        Assignee Philip Harvey [ philharveyonline ] Keith Wall [ k-wall ]
        Philip Harvey added a comment -

        please could you review. Thanks.

        Philip Harvey made changes -
        Status In Progress [ 3 ] Ready To Review [ 10006 ]
        Philip Harvey made changes -
        Summary CLONE - Java Performance Test and Visualisation unit test timeouts insufficient for slow CI servers CLONE - Java Performance Test unit test timeouts insufficient for slow CI servers
        Philip Harvey made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Philip Harvey made changes -
        Description Java Performance Test and Visualisation unit tests should subclass QpidTestCase, not TestCase, primarily because QpidTestCase logs the test name at the start and end of each test, thereby allowing you to identify which test each line of logging came from. Java Performance Test and Visualisation unit tests sometimes fail because of timeouts. These appear to be simply caused by slow CI servers.
        Philip Harvey made changes -
        Assignee Keith Wall [ k-wall ] Philip Harvey [ philharveyonline ]
        Philip Harvey made changes -
        Field Original Value New Value
        Link This issue is a clone of QPID-4605 [ QPID-4605 ]
        Philip Harvey created issue -

          People

          • Assignee:
            Keith Wall
            Reporter:
            Philip Harvey
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development