Qpid
  1. Qpid
  2. QPID-4509

HA backup broker does not properly increment the alternate exchange user count

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.20
    • Fix Version/s: None
    • Component/s: C++ Clustering
    • Labels:
      None

      Description

      Description of problem:
      When an exchange or queue that utilizes an alternate exchange is replicated to a backup broker, the backup broker does not increment the user count on the alternate exchange. This will incorrectly allow an alternate exchange to be deleted when it is still in use and will incorrectly prevent a exchange from being deleted when it is no longer an alternate exchange.

      Version-Release number of selected component (if applicable):
      Qpid 0.18

      How reproducible:
      100%

      Steps to Reproduce:
      1. Start primary and backup HA brokers
      2. Create an exchange to use as the alternate
      3. Create a queue or exchange w/ the alternate set to the previously create exchange
      4. Fail the primary and promote the backup
      5. Delete the alternate exchange

      Actual results:
      The alternate exchange is deleted while still in use

      Expected results:
      The client should receive a not-allowed exception

      See also: https://bugzilla.redhat.com/show_bug.cgi?id=886656

        Activity

        Alan Conway created issue -
        Alan Conway made changes -
        Field Original Value New Value
        Description Description of problem:
        When an exchange or queue that utilizes an alternate exchange is replicated to a backup broker, the backup broker does not increment the user count on the alternate exchange. This will incorrectly allow an alternate exchange to be deleted when it is still in use and will incorrectly prevent a exchange from being deleted when it is no longer an alternate exchange.

        Version-Release number of selected component (if applicable):
        Qpid 0.18

        How reproducible:
        100%

        Steps to Reproduce:
        1. Start primary and backup HA brokers
        2. Create an exchange to use as the alternate
        3. Create a queue or exchange w/ the alternate set to the previously create exchange
        4. Fail the primary and promote the backup
        5. Delete the alternate exchange
          
        Actual results:
        The alternate exchange is deleted while still in use

        Expected results:
        The client should receive a not-allowed exception
        Description of problem:
        When an exchange or queue that utilizes an alternate exchange is replicated to a backup broker, the backup broker does not increment the user count on the alternate exchange. This will incorrectly allow an alternate exchange to be deleted when it is still in use and will incorrectly prevent a exchange from being deleted when it is no longer an alternate exchange.

        Version-Release number of selected component (if applicable):
        Qpid 0.18

        How reproducible:
        100%

        Steps to Reproduce:
        1. Start primary and backup HA brokers
        2. Create an exchange to use as the alternate
        3. Create a queue or exchange w/ the alternate set to the previously create exchange
        4. Fail the primary and promote the backup
        5. Delete the alternate exchange
          
        Actual results:
        The alternate exchange is deleted while still in use

        Expected results:
        The client should receive a not-allowed exception

        See also: https://bugzilla.redhat.com/show_bug.cgi?id=886656
        Alan Conway added a comment -

        Duplicate of QPID-4508

        Alan Conway made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2d 1h 16m 1 Alan Conway 19/Dec/12 15:44

          People

          • Assignee:
            Alan Conway
            Reporter:
            Alan Conway
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development