Qpid
  1. Qpid
  2. QPID-4337

qpid-tools' SSL support for systems with python < 2.6 is broken

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.18
    • Fix Version/s: 0.19
    • Component/s: Python Client, Tools
    • Labels:
      None
    • Environment:

      Linux with python release 2.4 installed (Centos 5)

      Description

      Since release 2.6, python's SSL support is based on OpenSSL. Prior to 2.6, it was based on a more-limited implementation.

      It appears that this earlier implementation may fail to connect when the underlying socket is configured as non blocking, or configured with a timeout.

      This causes some of the qpid tools to fail to connect when used with SSL. For example, qpid-config.

      Also, the use of the older version of SSL's client-authentication appears to be broken.

        Activity

        Hide
        Ken Giusti added a comment -

        See review-board for patch:

        https://reviews.apache.org/r/7207/

        Show
        Ken Giusti added a comment - See review-board for patch: https://reviews.apache.org/r/7207/
        Show
        Ken Giusti added a comment - Fixed: http://svn.apache.org/viewvc?view=revision&revision=1388544

          People

          • Assignee:
            Ken Giusti
            Reporter:
            Ken Giusti
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development