Qpid
  1. Qpid
  2. QPID-4332

Java Broker logs "Warning: The encoding 'UTF-8' is not supported by the Java runtime." in response to some LoggingMangement operations

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.18
    • Fix Version/s: 0.19
    • Component/s: None
    • Labels:
      None

      Description

      The Java Broker logs a warning to stderr in response to the use of JMX LoggingManagement operations setConfigFileLoggerLevel and setConfigFileRootLoggerLevel.

      Warning:  The encoding 'UTF-8' is not supported by the Java runtime.
      

      The warning appears not to cause a functional issue, the log4j file is still successfully written with the changes.

      It appears the problem is the visibility of classes beneath java.nio.charset to the management-jmx bundle.

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Keith Wall
              Reporter:
              Keith Wall
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development