Qpid
  1. Qpid
  2. QPID-4187

Management ACL logging sometimes prints N/A instead of user name

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.16
    • Fix Version/s: 0.19
    • Component/s: Java Broker
    • Labels:
      None

      Description

      When testing the fix for QPID-4186 we noticed that the "log actor" portion of our management ACL authorization logging sometimes prints N/A where the user name should be.

      For example, this happens if you've connected JConsole using "reconnect" rather than a new connection.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          2h 34m 1 Robbie Gemmell 03/Aug/12 15:24
          In Progress In Progress Resolved Resolved
          14s 1 Robbie Gemmell 03/Aug/12 15:25
          Resolved Resolved Closed Closed
          922d 5h 41m 1 Rob Godfrey 11/Feb/15 20:06
          Rob Godfrey made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Robbie Gemmell made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Robbie Gemmell added a comment -

          Patch applied.

          Robbie Gemmell made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Philip Harvey added a comment -

          Reviewed the patch - looks good.

          Alex Rudyy made changes -
          Assignee Philip Harvey [ philharveyonline ] Robbie Gemmell [ gemmellr ]
          Alex Rudyy added a comment -

          Robbie,
          Could you please commit the patch?

          Alex Rudyy made changes -
          Alex Rudyy added a comment -

          Attached a patch resolving the issue with management logging.

          Phil,please review.

          Philip Harvey made changes -
          Description When testing the fix for QPID-4185 we noticed that the "log actor" portion of our management ACL authorization logging sometimes prints N/A where the user name should be.

          For example, this happens if you've connected JConsole using "reconnect" rather than a new connection.
          When testing the fix for QPID-4186 we noticed that the "log actor" portion of our management ACL authorization logging sometimes prints N/A where the user name should be.

          For example, this happens if you've connected JConsole using "reconnect" rather than a new connection.
          Philip Harvey made changes -
          Field Original Value New Value
          Link This issue relates to QPID-4186 [ QPID-4186 ]
          Philip Harvey added a comment -

          The problem is that ManagementActor caches its log message per-thread name.

          When JConsole reconnects the thread name doesn't change so ManagementActor uses its cached log string containing N/A, even though the user name is now available in the thread's Subject.

          Philip Harvey created issue -

            People

            • Assignee:
              Robbie Gemmell
              Reporter:
              Philip Harvey
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development