Qpid
  1. Qpid
  2. QPID-3947

long subject causes encode errors in a loop

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.14, 0.16
    • Fix Version/s: 0.17
    • Component/s: C++ Client
    • Labels:
      None

      Description

      Steps to Reproduce:
      1. ./spout
      'amq.direct/AReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectAReallyLongSubjectARea'

      Actual results:
      spout cycles with output:
      2012-04-13 16:30:48 error Caught exception in state: 3 with event: 2: Could not
      encode string of 256 bytes as uint8_t string. (qpid/framing/Buffer.cpp:255)

      The problem is that any bounds checking on str8 fields is done only on encode, so application threads are not correctly notified.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        4m 58s 1 Gordon Sim 14/Apr/12 00:39
        Resolved Resolved Closed Closed
        471d 19h 13m 1 Justin Ross 29/Jul/13 19:53
        Justin Ross made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gordon Sim made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Gordon Sim created issue -

          People

          • Assignee:
            Gordon Sim
            Reporter:
            Gordon Sim
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development