Qpid
  1. Qpid
  2. QPID-3825

TransactionTimeoutTest.testProducerOpenCommit and others fails sporadically on slower boxes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 0.15
    • Fix Version/s: None
    • Component/s: Java Tests
    • Labels:
      None

      Description

      We see a sporadic failure on TransactionTimeoutTest test on some CI boxes:

      junit.framework.AssertionFailedError: Exception not thrown
      	at org.apache.qpid.test.unit.transacted.TransactionTimeoutTest.testProducerIdleCommitTwice(TransactionTimeoutTest.java:109)
      	at org.apache.qpid.test.utils.QpidBrokerTestCase.runBare(QpidBrokerTestCase.java:237)
      	at org.apache.qpid.test.utils.QpidTestCase.run(QpidTestCase.java:138)
      

      and

      org.apache.qpid.test.unit.transacted.TransactionTimeoutTest.testProducerOpenCommit
      
      Error Message
      
      Expected 10 but found 13 txn open messages
      
      Stacktrace
      
      junit.framework.AssertionFailedError: Expected 10 but found 13 txn open messages
      	at org.apache.qpid.test.unit.transacted.TransactionTimeoutTestCase.monitor(TransactionTimeoutTestCase.java:195)
      	at org.apache.qpid.test.unit.transacted.TransactionTimeoutTest.testProducerOpenCommit(TransactionTimeoutTest.java:179)
      	at org.apache.qpid.test.utils.QpidBrokerTestCase.runBare(QpidBrokerTestCase.java:237)
      	at org.apache.qpid.test.utils.QpidTestCase.run(QpidTestCase.java:138)
      

        Activity

        Rob Godfrey added a comment -

        No further work has been done on this JIRA in the last 3 years.

        Should issues with the test still remain (I think they probably do) a new JIRA should be raised with the correct fix version

        Robbie Gemmell added a comment -

        The changes seem reasonable, but we have still seen this fail since on said 'slower boxes'. The changes made have made them more reliable (e.g. over a week since failure on the ASF Jenkins nodes), but the issue is the test need to be largely reworked.

        I'm going to knock this back from RTR, and we can do some more work on them later to update them in more substantial ways.

        Keith Wall added a comment -

        Patch applied. Hi Robbie, can you review please?


          People

          • Assignee:
            Unassigned
            Reporter:
            Keith Wall
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development