Uploaded image for project: 'Qpid'
  1. Qpid
  2. QPID-3815

0-10 connections produce duplicate connection open log messages

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.14
    • Fix Version/s: 0.15
    • Component/s: Java Broker
    • Labels:
      None

      Description

      0-10 connections produce duplicate connection open log messages.

      This is not caught by the logging test covering these message because it is incorrectly allowing for extra log messages to cover the case where we previously used to log both the unsuccessfull (unsupported) 0-10 attempt and the subsequent 0-9 open messages when running the 0-9 test profiles, but since the removal of mina the logging now only occurs on connections which succeed in agreeing a protocol version.

      The underlying cause of the issue is that we are setting the NetworkConnection onto the ProtocolEngine twice, with the 0-10 open logging being present in this area causing it to be emitted twice.

        Activity

        gemmellr Robbie Gemmell added a comment -

        Keith, could you review this change please?

        Thanks,
        Robbie

        k-wall Keith Wall added a comment -

        Changes look good to me.


          People

          • Assignee:
            k-wall Keith Wall
            Reporter:
            gemmellr Robbie Gemmell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development