Qpid
  1. Qpid
  2. QPID-3525

On invoking Session#recover() in MessageListener the current message is acknowledged after being released in recover()

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.5, 0.6, 0.7, 0.8, 0.9, 0.10, 0.11, 0.12
    • Fix Version/s: 0.13
    • Component/s: Java Client
    • Labels:
      None

      Description

      On invoking of Session#recover() in MessageListener the current message is acknowledged after being released by recover()

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        1d 43m 1 Alex Rudyy 06/Oct/11 17:18
        In Progress In Progress Reviewable Reviewable
        50s 1 Alex Rudyy 06/Oct/11 17:19
        Reviewable Reviewable Resolved Resolved
        16h 58m 1 Robbie Gemmell 07/Oct/11 10:18
        Robbie Gemmell made changes -
        Status Ready To Review [ 10006 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Robbie Gemmell added a comment -

        Patch applied. This change also fixes a somewhat severe issues on the 0-8/9/9-1 protocol path caused by the changes in QPID-2471 which meant the client would not recover messages as requested, and instead could consume the resent messages during the recover operation. The existing tests which could show this was broken were however also disabled by the changes in QPID-2471.

        Alex Rudyy made changes -
        Assignee Alex Rudyy [ alex.rufous ] Robbie Gemmell [ gemmellr ]
        Alex Rudyy added a comment -

        Robbie, could you please review and apply a patch fixing the issue?

        Alex Rudyy made changes -
        Status In Progress [ 3 ] Ready To Review [ 10006 ]
        Alex Rudyy made changes -
        Alex Rudyy added a comment -

        Attached patch from Robbie Gemmell and me fixing the issue.

        Alex Rudyy made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        Alex Rudyy created issue -

          People

          • Assignee:
            Robbie Gemmell
            Reporter:
            Alex Rudyy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development