Qpid
  1. Qpid
  2. QPID-3390

the Java broker does not validate the exchange-declare arguments are supported

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6, 0.7, 0.8, 0.9, 0.10, 0.11, 0.12
    • Fix Version/s: 0.13
    • Component/s: Java Broker
    • Labels:
      None

      Description

      The Java broker does not currently validate the arguments supplied are supported, and simply ignores ones which are not known. The 0-10 spec requires that a 'NOT_IMPLEMENTED' session execution exception be raised when presented with an exchange declare argument the broker doesn't have knowledge of; this should be implemented.

        Activity

        Robbie Gemmell created issue -
        Robbie Gemmell made changes -
        Field Original Value New Value
        Issue Type Improvement [ 4 ] Bug [ 1 ]
        Robbie Gemmell made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Robbie Gemmell made changes -
        Status In Progress [ 3 ] Ready To Review [ 10006 ]
        Robbie Gemmell added a comment - - edited

        Hi Keith, can your review these changes please?

        The broker now validates the exchange-declare arguments to ensure none are present, since we don't currently support any. If arguments are found, an executionException is raised indicating support for the arguments is not implemented.

        A test was added to ensure the expected behaviour with nonsense argument, at the same time splitting 2 of the existing tests (which would now error due to the validation) into versions with valid arguments (for the C++ broker at least) and those with no arguments. This allows the rest of the functionality they test to be tested with the Java broker until such time as QPID-3392 is completed.

        Robbie Gemmell made changes -
        Assignee Robbie Gemmell [ gemmellr ] Keith Wall [ k-wall ]
        Robbie Gemmell made changes -
        Description The Java broker does not currently validate the arguments supplied are supported, and simply ignores ones which are not. The 0-10 spec requires that a 'NOT_IMPLEMENTED' session execution exception be raised when presented with an exchange declare argument the broker doesn't have knowledge of; this should be implemented. The Java broker does not currently validate the arguments supplied are supported, and simply ignores ones which are not known. The 0-10 spec requires that a 'NOT_IMPLEMENTED' session execution exception be raised when presented with an exchange declare argument the broker doesn't have knowledge of; this should be implemented.
        Keith Wall added a comment -

        Hi Robbie,

        I've reviewed the change and I have no comments.

        cheers Keith.

        Keith Wall made changes -
        Status Ready To Review [ 10006 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Rob Godfrey made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        9m 53s 1 Robbie Gemmell 04/Aug/11 12:55
        In Progress In Progress Reviewable Reviewable
        35m 41s 1 Robbie Gemmell 04/Aug/11 13:31
        Reviewable Reviewable Resolved Resolved
        4d 9h 17m 1 Keith Wall 08/Aug/11 22:49
        Resolved Resolved Closed Closed
        1282d 22h 17m 1 Rob Godfrey 11/Feb/15 20:06

          People

          • Assignee:
            Keith Wall
            Reporter:
            Robbie Gemmell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development