Qpid
  1. Qpid
  2. QPID-3070

SessionComplete command sent for empty range

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: 0.11
    • Component/s: Java Broker, Java Client
    • Labels:
      None

      Description

      The 0-10 AMQP protocol implementation sends a SessionComplete command with an empty RangeSet, which will be replied to with a SessionKnownComplete and a similar empty or null RangeSet (these are equivalent on the wire) iff the TimelyReply field is set to true in the request.

      I think that the initial empty SessionComplete (caused by a call to flushProcessed normally) should never be sent, so adding a check for range.size() > 0 before sending should do this.

        Activity

        Gordon Sim added a comment -

        Certainly there is no value to sending an empty SessionCompleted

        Rajith Attapattu added a comment -

        I have noticed this during my testing and wanted to get Rafael Scholming's opinion before changing the behaviour.
        I assume he had that in place for some reason. It could perhaps be a hack that is no longer needed.

        However I'd be a bit conservative and not change the behaviour closer to a release until we understand the reason behind the existing behaviour.
        I believe Rafi should be around soon after the AMQP WG Connectathon, and it's best to get his opinion on this before we make any changes.

        Andrew Kennedy added a comment -

        Ok, I will await further comments.

        Rafael H. Schloming added a comment -

        I don't think there was any good reason for it. I'd go ahead with the change.

        Andrew Kennedy added a comment -

        Rafi, can you confirm this is OK, please?

        Robbie Gemmell added a comment -

        Looks good to me, closing out.


          People

          • Assignee:
            Robbie Gemmell
            Reporter:
            Andrew Kennedy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development