Qpid
  1. Qpid
  2. QPID-2727

./src/qpidd --load-module ./src/.libs/cluster.so --cluster-name blah --known-hosts-url amqpx:blah segfaults

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7
    • Component/s: C++ Broker
    • Labels:
      None

      Activity

      Gordon Sim created issue -
      Gordon Sim added a comment -

      The problem is that the exception in the Broker constructor means the Brokers
      destructor does not get called, however the Plugin::Target superclasses
      destructor does, this invokes all registered finalisers. The finaliser
      registered by the cluster calls back on the now dangling pointer to the broker.

      Gordon Sim made changes -
      Field Original Value New Value
      Resolution Fixed [ 1 ]
      Status Open [ 1 ] Resolved [ 5 ]
      Justin Ross made changes -
      Status Resolved [ 5 ] Closed [ 6 ]

        People

        • Assignee:
          Gordon Sim
          Reporter:
          Gordon Sim
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development