Qpid
  1. Qpid
  2. QPID-2641

The bitwise AND operator used instead of logical AND in QpidLog4JConfigurator.java

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.7
    • Component/s: None
    • Labels:
      None

      Description

      The following line:
      if(log4jConfiguredString.equals("") & ! log4jConfiguredString.equals(levelString))

      wanted to use the logical AND (&&) operator instead of & (bitwise AND).

        Issue Links

          Activity

          Robbie Gemmell added a comment - - edited

          Closing as duplicate of QPID-2642


            People

            • Assignee:
              Sorin Suciu
              Reporter:
              Sorin Suciu
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development