Details

    • Type: Test Test
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.7
    • Fix Version/s: 0.7
    • Component/s: C++ Broker
    • Labels:
      None
    • Environment:

      Fedora Rawhide

      Description

      This happents quite regularly in last week but still pretty randomly
      (sometimes whole make checks works well on the same revision
      on which it did not a while ago). I do `rm -rf ~/.qpidd; qpid clean -xfd'
      before every compilation. And still cluster_read_credit test fails because
      of following error:

      (relevant part of `make check' output follows)

      2010-04-22 11:54:31 warning Connection closed
      2010-04-22 11:54:31 warning Connect failed: Connection refused
      2010-04-22 11:54:31 warning Connection closed
      Failed: Cannot establish a connection
      2010-04-22 11:54:31 critical Unexpected error: Removing stale lock file /home/jsarenik/.qpidd/qpidd.41519.pid
      Errors stopping brokers on ports: 41519
      FAIL: cluster_read_credit

      1. cluster0.log
        7 kB
        Jan Sarenik
      2. core-analyze-1.txt
        18 kB
        Jan Sarenik

        Activity

        Alan Conway made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Duplicate [ 3 ]
        Alan Conway added a comment -

        Closed as duplicate of QPID-2552

        Jan Sarenik made changes -
        Comment [ Cleansed output. ]
        Jan Sarenik made changes -
        Attachment core-analyze-1.txt [ 12444119 ]
        Jan Sarenik made changes -
        Attachment core-analyze-1.txt [ 12444118 ]
        Jan Sarenik made changes -
        Attachment core-analyze-1.txt [ 12444118 ]
        Jan Sarenik added a comment -

        After all it really seems to be related to QPID-2552 and new Glibc.
        See this gdb backtrace.

        Jan Sarenik made changes -
        Attachment cluster0.log [ 12444114 ]
        Jan Sarenik added a comment - - edited

        I am attaching a recent cluster0.log file which should contain
        some relevant info because the cluster_read_credit failed
        during that run.

        This was done on qpid r942293.

        Jan Sarenik added a comment -

        Thanks for feed-back, Alan. I realized now that it is probably connected to
        https://issues.apache.org/jira/browse/QPID-2552

        Alan Conway added a comment -

        The stale lock file is just a symptom. The real problem here is that the broker is crashing or exiting before the client connects. The stale lock file just indicates that we tried to stop a broker that was not running.

        I have not been able to reproduce this so far. If you can reproduce it I'd like to see if the cluster0.log file has any useful information. I'll keep trying to reproduce it.

        Jan Sarenik added a comment -

        From the e-mail I sent recently, the error message is generally the same:

        • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
          PASS: run_cluster_test
          2010-04-29 20:27:17 warning Connection closed
          2010-04-29 20:27:17 warning Connect failed: Connection refused
          2010-04-29 20:27:17 warning Connection closed
          Failed: Cannot establish a connection
          2010-04-29 20:27:17 critical Unexpected error: Removing stale lock file /tmp/qpidd.46939.pid
          Errors stopping brokers on ports: 46939
          FAIL: cluster_read_credit
          PASS: test_watchdog
        • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

        And this was run on qpid-r939184.

        Jan Sarenik made changes -
        Field Original Value New Value
        Assignee Alan Conway [ aconway ]
        Jan Sarenik added a comment -

        I found this issue already reported, reassigning to you
        as requested in e-mail Message-ID: <4BDEDEBE.7030008@redhat.com>

        You can find my unsuccessful try to cope with this issue at
        http://github.com/jsarenik/qpid/commit/23713b2fc999a1fc4119ba06a7296ecd3f8260d4

        Jan Sarenik added a comment -

        If it is caused by the previous test, the previous is

        PASS: run_cluster_test

        Jan Sarenik created issue -

          People

          • Assignee:
            Alan Conway
            Reporter:
            Jan Sarenik
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development