Qpid
  1. Qpid
  2. QPID-2361

exchange configuration attributes are ignored when configuration is placed in virtualhosts.xml

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.5, 0.6
    • Fix Version/s: 0.7
    • Component/s: Java Broker
    • Labels:
      None

      Description

      When configuring exchanges in virtualhosts.xml, only the name is picked up. The type element is ignored and the default "direct" is used. Similarly, the durable element is ignored and the default "false" is used. As such it is impossible to define anything other than a transient direct exchange within virtualhosts.xml.

      When configured within the main config.xml file, the configuration is picked up and used as expected.

      1. 0001-QPID-2361-branch.patch
        4 kB
        Andrew Kennedy
      2. 0001-QPID-2361-trunk.patch
        4 kB
        Andrew Kennedy

        Issue Links

          Activity

          Robbie Gemmell created issue -
          Andrew Kennedy made changes -
          Field Original Value New Value
          Link This issue blocks QPID-2360 [ QPID-2360 ]
          Andrew Kennedy added a comment -

          This is caused by the same issue as QPID-2360.

          Andrew Kennedy made changes -
          Link This issue blocks QPID-2360 [ QPID-2360 ]
          Andrew Kennedy made changes -
          Link This issue is related to QPID-2360 [ QPID-2360 ]
          Robbie Gemmell made changes -
          Assignee Robbie Gemmell [ gemmellr ]
          Robbie Gemmell made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Robbie Gemmell made changes -
          Status In Progress [ 3 ] Ready To Review [ 10006 ]
          Andrew Kennedy added a comment -

          Patch and tests to enable resolution of default virtualhost name when defined in an external virtualhosts file.

          Andrew Kennedy made changes -
          Attachment 0001-QPID-2361-branch.patch [ 12440751 ]
          Attachment 0001-QPID-2361-trunk.patch [ 12440752 ]
          Robbie Gemmell made changes -
          Status Ready To Review [ 10006 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Rob Godfrey made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          59d 54m 1 Robbie Gemmell 26/Mar/10 12:33
          In Progress In Progress Reviewable Reviewable
          4d 1h 16m 1 Robbie Gemmell 30/Mar/10 14:50
          Reviewable Reviewable Resolved Resolved
          246d 9h 26m 1 Robbie Gemmell 01/Dec/10 23:16
          Resolved Resolved Closed Closed
          1532d 20h 49m 1 Rob Godfrey 11/Feb/15 20:06

            People

            • Assignee:
              Robbie Gemmell
              Reporter:
              Robbie Gemmell
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development