Qpid
  1. Qpid
  2. QPID-2328

Querying for 500 objects causes C++ based ruby console to hang

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7
    • Labels:
      None
    • Environment:

      Version:

      qmf-0.5.829175-3

      Description

      Using the test framework at http://github.com/movitto/qmf/ we were able to cause the console to hang and require a SIGKILL to stop it by querying for > 450 or so objects.

      To reproduce:

      in project_stress/stress_agent/src run:

      ./stress_agent -n 500

      And in project_stress/ruby/bin run:

      ./console.rb -t testobject -s

      If you try rerunning the agent with fewer objects you will see what normal output looks like.

      1. qmf_race_fixes_try_2.patch
        2 kB
        Ian Main
      2. qmf_race_fixes.patch
        3 kB
        Ian Main

        Activity

        Ian Main added a comment -

        This patch fixes all the race conditions found to date including several other bugs listed here. I'll look them up and comment after.

        Ian Main added a comment -

        The above patch also fixes QPID-2330, and probably QPID-2334.

        Ian Main added a comment -

        This is still not fixed in trunk. Attached is another patch that applies to trunk.


          People

          • Assignee:
            Ted Ross
            Reporter:
            Ian Main
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development