Qpid
  1. Qpid
  2. QPID-2165

MINANetworkDriverTest fails to socket already in use

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.7
    • Component/s: Java Tests
    • Labels:
      None

      Description

      Mail from Rajith:

      The above test fails occasionally.
      It could be due to the port is already in use? perhaps caused by a
      previous test not cleaning up properly?
      Sorry I haven't had time to dig deeper, but hope the following will help.

      Testcase: testBindOpen took 0.15 sec
      Testcase: testBindOpenCloseOpen took 0.004 sec
      Caused an ERROR
      Could not bind to *:2323
      java.net.BindException: Could not bind to *:2323
      at org.apache.qpid.transport.network.mina.MINANetworkDriver.bind(MINANetworkDriver.java:174)
      at org.apache.qpid.transport.network.mina.MINANetworkDriverTest.testBindOpenCloseOpen(MINANetworkDriverTest.java:108)

      Testcase: testBindPortInUse took 0.008 sec
      FAILED
      First bind should not fail
      junit.framework.AssertionFailedError: First bind should not fail
      at org.apache.qpid.transport.network.mina.MINANetworkDriverTest.testBindPortInUse(MINANetworkDriverTest.java:136)

        Activity

        Marnie McCormack added a comment -

        Moving items unlikely to be in 0.6 out to 0.7 (since not in progress)

        Robbie Gemmell added a comment -

        Cant find the JIRA right now, but Martin applied an update some time back to resolve this issue and I havent been seeing it occur so I believe this is resolved and am marking the JIRA accordingly.


          People

          • Assignee:
            Aidan Skinner
            Reporter:
            Aidan Skinner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development