Qpid
  1. Qpid
  2. QPID-2082

Put all of the C++ code in the source tree into a namespace

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.17
    • Component/s: C++ Broker, C++ Client
    • Labels:
      None

      Description

      Currently the test and example code is in the global namespace.

      It would be neater especially in a code browser that sorts flat by namespace to put all the code into a namespace.

        Activity

        Andrew Stitcher created issue -
        Andrew Stitcher added a comment -

        I've now put all of the test code into the qpid::tests namespace.

        However I've left the example code in the global namespace so as not to add irrelevant details to the examples.

        There are still a few things in the global namespace that are part of the qpidd main program, this code should probably be moved into the src/qpid/broker directory and put in the qpid::broker namespace

        Gordon Sim added a comment -

        Can we close this issue?

        Andrew Stitcher added a comment -

        Just checked again and there is now more code again in the global namespace so the issue is still unfixed (it is a marked as minor)

        Andrew Stitcher added a comment -

        All of the qpid code except for examples is now in some namespace.
        I think there would be an argument to put the example code in a namespace too, but for the present it is left as-is.

        Andrew Stitcher made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 0.17 [ 12320179 ]
        Resolution Fixed [ 1 ]
        Justin Ross made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Andrew Stitcher
            Reporter:
            Andrew Stitcher
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development