Uploaded image for project: 'Qpid Proton'
  1. Qpid Proton
  2. PROTON-824

Windows fails testIdleTimeout with assert p.conn.remote_condition

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: proton-0.9
    • Fix Version/s: None
    • Component/s: proton-c
    • Environment:
      Windows Server 2008 or 2012
      Visual studio 2010, x86

      Description

      1: proton_tests.engine.ServerTest.testIdleTimeout ......................... fail
      1: Error during test:  Traceback (most recent call last):
      1:     File "D:/Users/crolke/git/rh-qpid-proton/tests/python/proton-test", line 355, in run
      1:       phase()
      1:     File "D:\Users\crolke\git\rh-qpid-proton\tests\python\proton_tests\engine.py", line 1919 (or so), in testIdleTimeout
      1:       assert p.conn.remote_condition
      1:   AssertionError
      

      Playing with Program explicit timeout (trying 10 instead of 3) gets the test to pass sometimes. It passes sometimes with 3 as well but normally fails.

      In debugging this it looks like there as no synchronization between what a test will show through print statements and what the proton library shows through PN_TRACE_FRM statements. Are there any hints to lining these up?

        Attachments

          Activity

            People

            • Assignee:
              cliffjansen Clifford Jansen
              Reporter:
              chug Charles E. Rolke
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: