Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.6
    • Component/s: proton-j
    • Labels:
      None
    1. PROTON-440.patch
      2 kB
      Hiram Chirino

      Issue Links

        Activity

        Hiram Chirino added a comment -

        Works for me on OS X now.

        Rafael H. Schloming added a comment -

        Thanks for catching the println. I've removed it. I have no way of testing on OSX, so I'm just going with hiram's say so that this addresses the OSX issue.

        ASF subversion and git services added a comment -

        Commit 1532453 from rhs@apache.org in branch 'proton/trunk'
        [ https://svn.apache.org/r1532453 ]

        PROTON-440: removed accidental println

        Robbie Gemmell added a comment -

        The patch doesn't seem to match the commit, which included a seemingly unrelated dependency change and a System.out.println call:

        @@ -192,6 +192,7 @@
                 {
                     SocketChannel channel = SocketChannel.open();
                     channel.configureBlocking(false);
        +            System.out.println("host:port:" + host + ", " + port);
                     channel.connect(new InetSocketAddress(host, port));
                     return createConnector(channel, context);
                 }
        
        ASF subversion and git services added a comment -

        Commit 1531508 from rhs@apache.org in branch 'proton/trunk'
        [ https://svn.apache.org/r1531508 ]

        PROTON-440: fix from hiram

        Hiram Chirino added a comment -

        Attaching patch that fixes the issue. Seems like blocking selects were not being done properly.

        Hiram Chirino added a comment -

        Test fails with:

        -------------------------------------------------------
        T E S T S
        -------------------------------------------------------
        Running org.apache.qpid.proton.hawtdispatch.api.SampleTest
        Oct 11, 2013 11:32:58 AM org.apache.qpid.proton.driver.impl.DriverImpl doWait
        SEVERE: Exception when waiting for IO Event
        java.io.IOException: Invalid argument
        at sun.nio.ch.KQueueArrayWrapper.kevent0(Native Method)
        at sun.nio.ch.KQueueArrayWrapper.poll(KQueueArrayWrapper.java:159)
        at sun.nio.ch.KQueueSelectorImpl.doSelect(KQueueSelectorImpl.java:103)
        at sun.nio.ch.SelectorImpl.lockAndDoSelect(SelectorImpl.java:87)
        at sun.nio.ch.SelectorImpl.select(SelectorImpl.java:98)
        at org.apache.qpid.proton.driver.impl.DriverImpl.doWait(DriverImpl.java:83)
        at org.apache.qpid.proton.messenger.impl.MessengerImpl.waitUntil(MessengerImpl.java:684)
        at org.apache.qpid.proton.messenger.impl.MessengerImpl.waitUntil(MessengerImpl.java:653)
        at org.apache.qpid.proton.messenger.impl.MessengerImpl.recv(MessengerImpl.java:313)
        at org.apache.qpid.proton.hawtdispatch.test.MessengerServer$1.run(MessengerServer.java:48)
        at java.lang.Thread.run(Thread.java:722)

        Tests run: 2, Failures: 1, Errors: 1, Skipped: 0, Time elapsed: 0.295 sec <<< FAILURE!
        test(org.apache.qpid.proton.hawtdispatch.api.SampleTest) Time elapsed: 0.249 sec <<< FAILURE!
        junit.framework.AssertionFailedError: expected:<10> but was:<0>
        at junit.framework.Assert.fail(Assert.java:50)
        at junit.framework.Assert.failNotEquals(Assert.java:287)
        at junit.framework.Assert.assertEquals(Assert.java:67)
        at junit.framework.Assert.assertEquals(Assert.java:199)
        at junit.framework.Assert.assertEquals(Assert.java:205)
        at org.apache.qpid.proton.hawtdispatch.api.SampleTest.test(SampleTest.java:278)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
        at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
        at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
        at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
        at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
        at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:30)
        at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47)
        at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
        at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
        at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
        at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
        at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
        at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
        at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:252)
        at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:141)
        at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:112)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.apache.maven.surefire.util.ReflectionUtils.invokeMethodWithArray(ReflectionUtils.java:189)
        at org.apache.maven.surefire.booter.ProviderFactory$ProviderProxy.invoke(ProviderFactory.java:165)
        at org.apache.maven.surefire.booter.ProviderFactory.invokeProvider(ProviderFactory.java:85)
        at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:115)
        at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:75)

        test(org.apache.qpid.proton.hawtdispatch.api.SampleTest) Time elapsed: 0.251 sec <<< ERROR!
        java.lang.RuntimeException: Messenger server had problems
        at org.apache.qpid.proton.hawtdispatch.test.MessengerServer.stop(MessengerServer.java:104)
        at org.apache.qpid.proton.hawtdispatch.api.SampleTest.stopServer(SampleTest.java:42)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
        at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
        at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
        at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:36)
        at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47)
        at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
        at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
        at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
        at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
        at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
        at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
        at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:252)
        at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:141)
        at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:112)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.apache.maven.surefire.util.ReflectionUtils.invokeMethodWithArray(ReflectionUtils.java:189)
        at org.apache.maven.surefire.booter.ProviderFactory$ProviderProxy.invoke(ProviderFactory.java:165)
        at org.apache.maven.surefire.booter.ProviderFactory.invokeProvider(ProviderFactory.java:85)
        at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:115)
        at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:75)
        Caused by: java.lang.RuntimeException: java.io.IOException: Invalid argument
        at org.apache.qpid.proton.driver.impl.DriverImpl.doWait(DriverImpl.java:108)
        at org.apache.qpid.proton.messenger.impl.MessengerImpl.waitUntil(MessengerImpl.java:684)
        at org.apache.qpid.proton.messenger.impl.MessengerImpl.waitUntil(MessengerImpl.java:653)
        at org.apache.qpid.proton.messenger.impl.MessengerImpl.recv(MessengerImpl.java:313)
        at org.apache.qpid.proton.hawtdispatch.test.MessengerServer$1.run(MessengerServer.java:48)
        at java.lang.Thread.run(Thread.java:722)
        Caused by: java.io.IOException: Invalid argument
        at sun.nio.ch.KQueueArrayWrapper.kevent0(Native Method)
        at sun.nio.ch.KQueueArrayWrapper.poll(KQueueArrayWrapper.java:159)
        at sun.nio.ch.KQueueSelectorImpl.doSelect(KQueueSelectorImpl.java:103)
        at sun.nio.ch.SelectorImpl.lockAndDoSelect(SelectorImpl.java:87)
        at sun.nio.ch.SelectorImpl.select(SelectorImpl.java:98)
        at org.apache.qpid.proton.driver.impl.DriverImpl.doWait(DriverImpl.java:83)
        ... 5 more

        Results :

        Failed tests: test(org.apache.qpid.proton.hawtdispatch.api.SampleTest): expected:<10> but was:<0>


          People

          • Assignee:
            Rafael H. Schloming
            Reporter:
            Hiram Chirino
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development