Qpid Proton
  1. Qpid Proton
  2. PROTON-290

Allow querying of unsent messages by tracker

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.6
    • Component/s: None
    • Labels:
      None

      Description

      messenger.status(tracker) returns PENDING until the message is either
      accepted or rejected by the recipient.

      Allow distinguishing between buffered locally and transmitted messages.

        Issue Links

          Activity

          Bozo Dragojevic created issue -
          Bozo Dragojevic made changes -
          Field Original Value New Value
          Link This issue is related to PROTON-289 [ PROTON-289 ]
          Rafael H. Schloming made changes -
          Fix Version/s 0.5 [ 12324004 ]
          Bozo Dragojevic made changes -
          Rafael H. Schloming made changes -
          Fix Version/s 0.5 [ 12324004 ]
          Rafael H. Schloming made changes -
          Fix Version/s 0.6 [ 12324883 ]
          Rafael H. Schloming made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Rafael H. Schloming [ rhs ]
          Resolution Fixed [ 1 ]
          Bozo Dragojevic added a comment -

          I think I just spotted a thinko in my logic. Buffered should return true if we do not have a delivery yet or if delivery is still buffered:

          -    return d && pn_delivery_buffered(d);
          +    return !d || pn_delivery_buffered(d);
          
          Bozo Dragojevic made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Rafael H. Schloming added a comment -

          Any chance you want to supply a test case?

          Bozo Dragojevic added a comment -

          Sounds fair

          Bozo Dragojevic added a comment -

          Here is a test for buffered() plus python binding update
          and a fixed implementation

          You'll need to remove all the prints I left in the patch.

          reason is this: I find it odd that all 100 messages immediately get
          a delivery! Is this really intended behavior?

          if this is going to remain the case, either old or new logic had the same result....

          Bozo Dragojevic made changes -
          ASF subversion and git services added a comment -

          Commit 1547027 from rhs@apache.org in branch 'proton/trunk'
          [ https://svn.apache.org/r1547027 ]

          PROTON-290: applied updated patch from Bozo

          Rafael H. Schloming made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          ASF subversion and git services added a comment -

          Commit 1547036 from rhs@apache.org in branch 'proton/trunk'
          [ https://svn.apache.org/r1547036 ]

          PROTON-290: skip buffered tests for java


            People

            • Assignee:
              Rafael H. Schloming
              Reporter:
              Bozo Dragojevic
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development