Uploaded image for project: 'Qpid Proton'
  1. Qpid Proton
  2. PROTON-273

Fix disabled ruby test "can have nil content"

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.6
    • Component/s: proton-c
    • Labels:
      None

      Description

      This test:

      proton-c/bindings/ruby/spec/qpid/proton/message_spec.rb:404: xit "can have nil content" do

      has been disabled by replacing "it" with "xit". The test is failing, fix the cause and re-enable.

        Activity

        jira-bot ASF subversion and git services added a comment -

        Commit 1528216 from Darryl L. Pierce in branch 'proton/trunk'
        [ https://svn.apache.org/r1528216 ]

        PROTON-273: Removed the content Rspec test for Ruby.

        Since the body of the message is accessed by the body property and not
        by content, this test is no longer necessary.

        Changed example apps to use body instead of content.


          People

          • Assignee:
            mcpierce Darryl L. Pierce
            Reporter:
            aconway Alan Conway
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development