Qpid Proton
  1. Qpid Proton
  2. PROTON-268

Messenger hang in pn_messenger_stop()

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.4
    • Fix Version/s: 0.5
    • Component/s: proton-c
    • Labels:
      None

      Description

      In some cases, a client that has sent messages and calls stop will stall until the receiver also stops. This appears to be caused by the receiver not processing the sender's transition to the closed state on the link.

        Activity

        Ken Giusti added a comment -

          People

          • Assignee:
            Ken Giusti
            Reporter:
            Ken Giusti
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development