Qpid Proton
  1. Qpid Proton
  2. PROTON-249

Build fails on Win8 / VS 2012 with path error

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.4
    • Fix Version/s: 0.5
    • Component/s: proton-j
    • Labels:
      None
    • Environment:
      Windows 8 64 bit w/ cmake v. 2.8.10.12 and Visual Studio 2012

      Description

      The build in Visual Studio generates one error, which is the following (from the build output):

      3> Building Java objects for proton-api.jar
      3> javac: file not found: C:\qpid-proton-0.4\proton-j\proton-api\src\main\java\org\apache\qpi\proton\driver\Connector.java
      3> Usage: javac <options> <source files>

      Note that the path is "qpi", not "qpid"

        Issue Links

          Activity

          Keith Wall added a comment -

          Patch applied. Note in the process of this work, we discovered a second issue affecting the ability to compile the Java bindings under Windows. This is being addressed separated under PROTON-254.

          Keith Wall added a comment -

          Marked as Blocker as this currently prevents users from successfully running the build on Windows, and I'm not aware of any reasonable workaround.

          Keith Wall added a comment - - edited

          I've successfully reproduced Paul's problem.

          The problem is the handling of long command lines under the Windows OS. It seems Windows looses a byte at every 8192 boundary within the command line – effectively limiting command lines to less than 8192 bytes. Our command line is ~11,000 characters long.

          We are currently testing a workaround which will use javac's @ flag to specify a file containing a list of source files, thus avoiding the requirement for long command lines. (A defect http://public.kitware.com/Bug/view.php?id=13028 was raised against Cmake's UseJava module but unfortunately this never got assigned and has been subsequently closed without action).


            People

            • Assignee:
              Keith Wall
              Reporter:
              Paul O'Fallon
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development