Uploaded image for project: 'Qpid Proton'
  1. Qpid Proton
  2. PROTON-2013

[OSX] Travis CI xcode7.3 10.11 image fails to run

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      At the moment the travis ci macOS job for xcode7.3 fails to run. This travis macOS image is based on 10.11 and the configuration utilizes brew to install required packages.

      The brew package install fails with

      Error: You are using macOS 10.11.
      
      We (and Apple) do not provide support for this old version.
      You will encounter build failures with some formulae.
      Please create pull requests instead of asking for help on Homebrew's GitHub,
      Discourse, Twitter or IRC. You are responsible for resolving any issues you
      experience, as you are running this old version.
      
      Error: Your Xcode (7.3.1) is outdated.
      Please update to Xcode 8.2.1 (or delete it).
      Xcode can be updated from the App Store.
      
      Error: A newer Command Line Tools release is available.
      Update them from Software Update in the App Store.
      
      The command "brew install libuv swig" failed and exited with 1 during .
      Your build has been stopped.

       

        Attachments

          Activity

            People

            • Assignee:
              rkieley Roddie Kieley
              Reporter:
              rkieley Roddie Kieley
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: