Pluto
  1. Pluto
  2. PLUTO-468

isPortletModeAllowed and isWindowStateAllowed do case-sensitve checks

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.4, 2.0.0
    • Fix Version/s: 2.0.0
    • Component/s: portlet container
    • Labels:
      None

      Description

      The code underlying these two methods convert the PortletMode or WindowState being checked to a string then compare it using String.equals to another string. Either PortletMode.equals and WindowState.equals need to be used or String.equalsIgnoreCase needs to be used.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          145d 2h 34m 1 Craig Doremus 25/Jul/08 04:37
          Mark Thomas made changes -
          Workflow Default workflow, editable Closed status [ 12565039 ] jira [ 12586163 ]
          Mark Thomas made changes -
          Workflow jira [ 12424872 ] Default workflow, editable Closed status [ 12565039 ]
          Craig Doremus made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          Craig Doremus added a comment -

          Duplicate of PLUO-462.

          Elliot Metsger made changes -
          Affects Version/s 2.0.0 [ 12312914 ]
          Fix Version/s 1.1.5 [ 12312652 ]
          Elliot Metsger made changes -
          Field Original Value New Value
          Link This issue is a clone of PLUTO-462 [ PLUTO-462 ]
          Elliot Metsger created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Elliot Metsger
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development