Pluto
  1. Pluto
  2. PLUTO-447

Old version of junit included via commons-cli in pluto-util

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.4
    • Fix Version/s: 1.2.0, 1.1.5
    • Component/s: build system
    • Labels:
      None

      Description

      The commons-cli dependency in pluto-util includes an old (3.7) version of JUnit as a transitive dependency.

      Adding the following to the commons-cli dependency in the pluto-util pom.xml fixes the problem:

      <exclusions>
      <exclusion>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      </exclusion>
      </exclusions>

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Elliot Metsger
            Reporter:
            Eric Dalquist
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development