Pluto
  1. Pluto
  2. PLUTO-439

Assembly code cannot parse Servlet 2.4 web.xml containing <jsp-config> tags

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.4
    • Fix Version/s: 1.1.5
    • Component/s: descriptor
    • Labels:
      None
    • Environment:
      Windows XP, Java 1.5.0_07

      Description

      I am trying to assemble a portlet using the ant tasks and an expception is being thrown when trying to parse a web.xml file containing:
      <web-app version="2.4" ...>
      <jsp-config>
      <taglib>
      ...
      </taglib>
      ....
      </jsp-config>
      </web-app>

      Looking through the source it appears that the WebAppDD needs to be updated to support the new wrapping element
      http://svn.apache.org/viewvc/portals/pluto/tags/pluto-1.1.4/pluto-descriptor-api/src/main/java/org/apache/pluto/descriptors/servlet/WebAppDD.java?annotate=556325

        Issue Links

          Activity

          Lee Butts created issue -
          Elliot Metsger made changes -
          Field Original Value New Value
          Assignee Elliot Metsger [ emetsger ]
          Hide
          Elliot Metsger added a comment -

          Scheduling for 1.1.5. Thanks for the report Lee!

          Show
          Elliot Metsger added a comment - Scheduling for 1.1.5. Thanks for the report Lee!
          Elliot Metsger made changes -
          Fix Version/s 1.2.0 [ 12312213 ]
          Fix Version/s 1.1.5 [ 12312652 ]
          Component/s build system [ 12310181 ]
          Component/s descriptor [ 12311615 ]
          Hide
          Elliot Metsger added a comment -

          Committed to the 1.1.x branch r608340. Lee can you verify that the fix works with your web.xml?

          Show
          Elliot Metsger added a comment - Committed to the 1.1.x branch r608340. Lee can you verify that the fix works with your web.xml?
          Hide
          Craig Doremus added a comment -

          This fix also needs to be applied to the 1.1-286-trunk-merge branch so it makes it into Pluto 2.0.

          Show
          Craig Doremus added a comment - This fix also needs to be applied to the 1.1-286-trunk-merge branch so it makes it into Pluto 2.0.
          Craig Doremus made changes -
          Fix Version/s 1.1-286-trunk-merge [ 12312669 ]
          Hide
          Lee Butts added a comment -

          Hi Elliot,

          sorry I took so long at getting round to try the fix.

          I can confirm that the assemble task now successfully runs over my 2.4 web.xml

          cheers

          Lee

          Show
          Lee Butts added a comment - Hi Elliot, sorry I took so long at getting round to try the fix. I can confirm that the assemble task now successfully runs over my 2.4 web.xml cheers Lee
          Elliot Metsger made changes -
          Link This issue is cloned as PLUTO-466 [ PLUTO-466 ]
          Elliot Metsger made changes -
          Link This issue is cloned as PLUTO-467 [ PLUTO-467 ]
          Elliot Metsger made changes -
          Fix Version/s 1.2.0 [ 12312213 ]
          Fix Version/s 2.0.0 [ 12312914 ]
          Elliot Metsger made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Mark Thomas made changes -
          Workflow jira [ 12417494 ] Default workflow, editable Closed status [ 12565031 ]
          Mark Thomas made changes -
          Workflow Default workflow, editable Closed status [ 12565031 ] jira [ 12585920 ]

            People

            • Assignee:
              Elliot Metsger
              Reporter:
              Lee Butts
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development