Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.4, 1.2.0
    • Component/s: descriptor
    • Labels:
      None
    • Environment:

      Description

      From Daniel Larsen:

      Here is the contents of
      pluto-util/target/surefire-reports/org.apache.pluto.util.assemble.ear.EarAssemblerTest.txt

      -------------------------------------------------------------------------------
      Test set: org.apache.pluto.util.assemble.ear.EarAssemblerTest
      -------------------------------------------------------------------------------
      Tests run: 6, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.954
      sec <<< FAILURE!
      testEarAssemblyInPlace(org.apache.pluto.util.assemble.ear.EarAssemblerTest)
      Time elapsed: 0.187 sec <<< FAILURE!
      junit.framework.AssertionFailedError: WAR archive did not contain any servlets
      at junit.framework.Assert.fail(Assert.java:47)
      at junit.framework.Assert.assertTrue(Assert.java:20)
      at org.apache.pluto.util.assemble.ear.EarAssemblerTest.validateEarAssembly(EarAssemblerTest.java:125)
      at org.apache.pluto.util.assemble.ear.EarAssemblerTest.testEarAssemblyInPlace(EarAssemblerTest.java:81)
      at org.apache.pluto.util.assemble.ear.EarAssemblerTest.testEarAssemblyInPlace(EarAssemblerTest.java:81)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at junit.framework.TestCase.runTest(TestCase.java:164)
      at junit.framework.TestCase.runBare(TestCase.java:130)
      at junit.framework.TestResult$1.protect(TestResult.java:106)
      at junit.framework.TestResult.runProtected(TestResult.java:124)
      at junit.framework.TestResult.run(TestResult.java:109)
      at junit.framework.TestCase.run(TestCase.java:120)
      at junit.framework.TestSuite.runTest(TestSuite.java:230)
      at junit.framework.TestSuite.run(TestSuite.java:225)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.junit.JUnitTestSet.execute(JUnitTestSet.java:213)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:138)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:125)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:132)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:290)
      at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:818)

      1. mvn.log
        40 kB
        Craig Doremus
      2. surefire-reports-pluto-390.zip
        12 kB
        Elliot Metsger

        Activity

        Craig Doremus added a comment -

        Here's a log of the console output when I run 'mvn test' from the root directory when I get the same errors that Daniel reported. I've also attached a copy of all the surefire reports for the pluto-util module where all the errors occur.

        I also should note that an earTest*tmp.dir directory seems to be created for each test run and not cleaned up.

        Elliot Metsger added a comment -

        From Craig:
        Elliot,
        I got the same surefire report. Attached is all files in the directory.
        Maven reported that 21 tests failed in this package.
        /Craig

        Craig Doremus added a comment -

        I removed my surefire report zip since Elliot also had added it.

        Elliot Metsger added a comment -

        Confirmed - this affects the 1.1.x branch as well.

        Elliot Metsger added a comment -

        File renameTo(File) was failing on windows, use FileUtils to copy the file if renameTo fails.


          People

          • Assignee:
            Elliot Metsger
            Reporter:
            Elliot Metsger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development