Pluto
  1. Pluto
  2. PLUTO-375

The ExpressionEvaluatorProxy for JSP 2.1 is unimplemented

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.3
    • Fix Version/s: 1.1.4, 1.2.0
    • Labels:
      None
    • Environment:
      Any JSP 2.1 Container (tested on Tomcat 6 and Jetty 6)

      Description

      The JSP 2.1 EL API is unsupported by pluto-taglibs. I'm attaching a patch to org.apache.pluto.tags.el.JSP21ExpressionEvaluatorProxy that seems to work for evaluating value expressions in a JSP 2.1 container. I tested this in Tomcat 6 and Jetty 6 using the pluto test suite.

      1. jsp21patch.txt
        3 kB
        Benjamin Gould

        Issue Links

          Activity

            People

            • Assignee:
              Elliot Metsger
              Reporter:
              Benjamin Gould
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development