Pluto
  1. Pluto
  2. PLUTO-243

PortalURLParser drops '/' characters when building render path

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0-beta1
    • Fix Version/s: 1.1.0
    • Component/s: portal driver
    • Labels:
      None

      Description

      The PortalURLParser doesn't preserve the '/' characters in non-control path elements. For example, the path info of "/context/servlet/some/random/path/__rp..." ends up setting the renderPath in the PortletURL to "somerandompath" instead of "/some/random/path"

      Line 129, probably just needs to be changed from
      renderPath.append(token);
      to
      renderPath.append('/').append(token);

        Activity

        Hide
        Craig Doremus added a comment -

        Made Fix Version 1.1.0

        Show
        Craig Doremus added a comment - Made Fix Version 1.1.0
        Hide
        Craig Doremus added a comment -

        Fixed title

        Show
        Craig Doremus added a comment - Fixed title
        Hide
        Craig Doremus added a comment -

        Fixed in SVN version 24830. Thank you, David, for the patch. The testsuite still works as before, but please retest with your custom portlet.

        Show
        Craig Doremus added a comment - Fixed in SVN version 24830. Thank you, David, for the patch. The testsuite still works as before, but please retest with your custom portlet.

          People

          • Assignee:
            Craig Doremus
            Reporter:
            David Hay
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development