Uploaded image for project: 'Pivot'
  1. Pivot
  2. PIVOT-978

Possible to get calendar dates in year 10000 and beyond

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4, 2.1
    • Fix Version/s: 2.1, 2.0.5
    • Component/s: wtk-terra
    • Labels:
      None
    • Environment:
      ALL

      Description

      Summary of the steps to reproduce (from QA tester of our application):
      1. click into the year field - it seems not possible to change the year, however:
      2. press 1 and a date of 10000 is entered
      3. press 2 and it's 20000
      4. press 3 and it's 30000 (if you press 3 first, it could be 3000 and so it would be valid)
      5. you get a error message e.g. Invalid year: 10000
      6. nevertheless you can change the year with the arrow keys/buttons but for every change you get the error message.

      You also get the error message if you go to the upper and lower bounds of the calender, which is the year 1582 and 10000 (both exclusive) by means of arrow keys / arrow buttons. You can change the year into the wrong direction if you are willing to confirm the error message on every keypress. And if you want to change the year back to some meaningful value, you have to confirm the error message again, until you hit a valid year. If in such a invalid year (e.g 1580), you can click on a day and the date will change to that date in 1583.

        Activity

        rwhitcomb Roger Whitcomb added a comment -

        branches/2.0.x:
        Sending core\src\org\apache\pivot\util\CalendarDate.java
        Sending wtk-terra\src\org\apache\pivot\wtk\skin\terra\TerraCalendarSkin.java
        Transmitting file data ..
        Committed revision 1703071.

        One very minor problem remains: still get exception when trying to display January 1583, because the beginning of the week is in 1582.


          People

          • Assignee:
            rwhitcomb Roger Whitcomb
            Reporter:
            rwhitcomb Roger Whitcomb
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development