Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: wtk-effects
    • Labels:
      None
    • Environment:
      OS: Arch64
      JVM: HotSpot 1.6.0_25

      Description

      Working with Transitions and ComponentMouseListeners, seems like reversing is not keeping up when mouse events happen too quickly. Attached is a test case where the bug can be reproduced: Hover the mouse quickly twice (mouseOver-mouseOut-mouseOver-mouseOut) over the component to see the bug.

      I've made some tests and it seems Transition#getPercentCompleted() reports a wrong value which is causing this behaviour, but I haven't been able to tackle the exact cause of the issue.

      1. PIVOT-749.patch
        3 kB
        Greg Brown
      2. Transition2.patch
        0.6 kB
        Edgar Merino
      3. Transition.diff
        1 kB
        Edgar Merino
      4. TestTransition.java
        5 kB
        Edgar Merino

        Activity

        Edgar Merino added a comment -

        I've found the problem, back when pivot was in incubation, I developed the ScaleTransiton class and I remembered it did not had this bug. I have an old copy of a svn snapshot of more than a year ago, and there's a little variable that fixes this bug in class org.apache.pivot.wtk.effects.Transition. I've attached the diff so you can verify the change, and it would be nice to know why it was changed in newer versions.

        Edgar Merino added a comment -

        By the way, it may be that those changes where made by me, perhaps that's the reason why it's not included in the current version. I remember I spent some time with transations back then, and this bugs seems familiar to me, I made some changes directly in the svn code but I guess I forgot to report some of them.

        Edgar Merino added a comment -

        I'm proposing a new patch (Transition2.patch) for this, a simpler one that also doesn't change previous functionality of the Transition class at all.

        Greg Brown added a comment -

        Hi Edgar,
        Can you apply the attached patch (PIVOT-749.patch) and let me know if it resolves your problem? Thanks.
        Greg

        Edgar Merino added a comment -

        Hello Greg, I can confirm the supplied patch (PIVOT-749.patch) solves the problem, thank you!

        Roger Whitcomb added a comment -

        Looks like the patch has been applied, and verified. So I am closing the issue.


          People

          • Assignee:
            Unassigned
            Reporter:
            Edgar Merino
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development