Pivot
  1. Pivot
  2. PIVOT-579

Provide additional Color schemes

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: wtk-terra
    • Labels:
      None

      Description

      Some reference here: http://apache-pivot-developers.417237.n3.nabble.com/Color-schemes-td963453.html#a963453

      Create color schemes (json) similar to defaults in the following platforms: Windows XP and Windows 7, Ubuntu 10.04, and if possible also on Max OS X.

        Issue Links

          Activity

          Sandro Martini added a comment -

          The related issue is not blocking for this, but can be useful to have more flexibility here.

          Sandro Martini added a comment -

          I have to restore a (backupped) version of the Dark colors containing comments to explain each color index where is used in the Terra skin, because this could be very useful to anyone wants to make a similar thing (last year when I've done this I had to check Pivot code many hours to understand this).
          So this could become a template for users, but in this case probably should be moved / copied inside the skin packages (for example the TerraTheme_dark.json now is in tutorials) ... we have to see what to do here.

          And for new json files, to simplify its usage, probably they should go inside packages of Terra skin, and if possible in a user-friendly package.

          To test the new look of any custom colors file, we have to remove some overrides there (if not all, at least some), in Kitchen Sink bxml files, to see "standard colors" of any component.
          And verify with the Component Explorer, if I can reload colors without restarting the application, but I think it will not be possible at the moment.

          Greg Brown added a comment -

          > I have to restore a (backupped) version of the Dark colors containing comments to explain each color index where is used in the Terra skin

          That information doesn't belong in the scheme descriptor file - it should go in the documentation for the skins themselves.

          > for new json files, to simplify its usage, probably they should go inside packages of Terra skin

          I think they should probably live in the same package as the existing descriptors (org.apache.pivot.wtk.skin.terra).

          > To test the new look of any custom colors file, we have to remove some overrides there (if not all, at least some), in Kitchen Sink bxml files

          This shouldn't be much of a problem - most examples use index setters which map directly to the color scheme.

          Sandro Martini added a comment - - edited

          Add also a file for Swing colors:
          this week I'm planning to add even this file, and check if all my references for colors are still valid (but testing them with ColorSchemeBuilder, and not with the KitchenSink because there some colors are overridden by bxml files).

          Last, update the JavaDoc page "package.html" for the Terra package, and write a reference table of where colors are used inside the Skin, to help users in create their custom color combinations.

          Sandro Martini added a comment - - edited

          Hi, the patch "reset_palette_colors_for_ColorSchemeBuilder.patch" is a little addition to the ColorSchemeBuilder utility, to add a Reset button so after any changes to one or more colors, I can reset the palette to default (at the start of the execution), and it's very useful during experiments on colors.
          Probably the two buttons now could have a better spacing (see screenshot), but it's a detail.

          Tell me if you like so I can commit.

          Note: during my tests I found a strange situation, where all colors have been put to black, but at screen I still see something (icons ok, and even some parts of the table could be ok) but there are other parts that probably are never repainted or are painter with a fixed color and not one from the palette ... comments ?
          Sorry, a little clarification: even the part on the left (and on top, on the right upper side) keep a non-black color as a background ... it is right ?
          You see the result in the screenshot in attach.

          Bye,
          Sandro

          Sandro Martini added a comment -

          add some documentation in the Terra package JavaDoc file

          Greg Brown added a comment -

          Hi Sandro,
          Just noticed your comment about the "all black" test. Only the example components are affected by the color changes - the spinners, etc. are not (so you can change the values without making the app unusable).
          G

          Sandro Martini added a comment -

          Hi Greg,

          > Only the example components are affected by the color changes - the spinners, etc. are not (so you can change the values without making the app unusable).
          So you means this is a desired effect here ?
          If yes, I agree with you (it's a good behavior in this case) ...

          So probably the only unwanted effect here is a small corner portion of the table view (small gray rectangle at the center of the screenshot). If confirmed, I could open a dedicated jira ticket for it.

          Sandro

          Greg Brown added a comment -

          > So you means this is a desired effect here ?

          Yes, this is by design.

          > probably the only unwanted effect here is a small corner portion of the table view

          I believe this was because TerraScrollPaneCornerSkin was ignoring the theme colors. It should be fixed now.

          Sandro Martini added a comment -

          added some documentation in the Terra package JavaDoc file on color palette usage in the Terra Skin, to help anyone wants to write their custom colors.

          TerraScrollPaneCornerSkin is fixed now ... many thanks to Greg for this.

          Sandro

          Sandro Martini added a comment -

          resolved, so now closing it.


            People

            • Assignee:
              Sandro Martini
              Reporter:
              Sandro Martini
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development