Pivot
  1. Pivot
  2. PIVOT-503

Using ClearType, bold text in Pivot 1.5 looks very bad

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: 1.5
    • Component/s: None
    • Labels:
      None
    • Environment:
      WIndows XP SP3, Dell 24" monitor, 1920x1200 resolution, NVIDIA Quadro FX 570 video card, Dell T5400 machine, Pivot 1.5 using SVN trunk on 5/24/10

      Description

      ClearType is enabled and setup using the Wizard for best readability on my system. Text rendered as BOLD (for instance in "Border" components) looks good in Pivot 1.4 (release), but looks very bad in 1.5 as of 5/24/10. See attached screenshots.

      1. osx-pivot.png
        1 kB
        Greg Brown
      2. screenshot-1.jpg
        2 kB
        Roger Whitcomb
      3. screenshot-2.jpg
        2 kB
        Roger Whitcomb
      4. windows-native.png
        0.9 kB
        Greg Brown
      5. windows-pivot.png
        0.9 kB
        Greg Brown

        Issue Links

          Activity

          Roger Whitcomb added a comment -

          This is from Pivot 1.4

          Roger Whitcomb added a comment -

          This is from 1.5 – notice the "O" characters appear taller and the verticals on the "N" appear thinner.

          Greg Brown added a comment -

          I can see that this is going to be an ongoing issue. Pivot 1.4 and earlier did not properly respect the system text AA hints, and many Windows users felt that text did not look appropriately native. I tend to prefer screenshot-1.jpg myself, but that is because it looks more like how text is rendered on Mac OS X, which I use (see osx-pivot.png). To me, even though it isn't perfect, windows-pivot.png does look a lot more like windows-native.png than osx-pivot.png.

          The fundamental problem is that Java2D does not use native text rendering but instead renders text internally using "hints" provided by the native platform. Some fonts (like Verdana) render reasonably well, but others don't look quite as good.

          It might be worth making this configurable in a later release (i.e. use native hints or use standard AA, which produces the OS X-like text).

          Roger Whitcomb added a comment -

          I like screenshot-1.jpg myself, but that I got using 1.4. screenshot-2.jpg (which I don't like) was what I got with 1.5 – it doesn't look like any of your screenshots. So, am I doing something different than you are?

          Greg Brown added a comment -

          The problem is that other Windows users did not like the way text was rendered in Pivot 1.4, which produced the result in screenshot-1.jpg. However, since it sounds like there may be at least one Windows user who does prefer the earlier style, supporting both in a future release may make sense.

          What font are you using? It doesn't look like Verdana 11 (the standard Terra font, which was used to produce the screenshots I took).

          Roger Whitcomb added a comment -

          I didn't do anything to change the font. Here is the declaration:

          <Border title=" INFORMATION " preferredWidth="460" preferredHeight="320"
          styles="

          color: Color value is invalid

          ">

          That's why I'm a little puzzled. I wouldn't mind either of your Windows screenshots, it' just the one I'm getting that I don't like. The "O" is fuzzy and looks too tall, and the verticals on the "N" look thin, neither of which I see in your Windows-native, nor windows-pivot screenshot.

          I'm wondering if something weird is going on with the Border component? Does it do something different that a straight label?

          Greg Brown added a comment -

          As a matter of fact, Border does work differently than Label. I'll take a look.

          Greg Brown added a comment -

          This is now fixed in both BorderSkin and TerraMeterSkin. For some reason, the standard AA hint was interfering with the text AA hint. Ensuring that AA is off when drawString() is called resolved the issue.

          Roger, thank you for catching this!

          Roger Whitcomb added a comment -

          Thank you for fixing it so promptly!


            People

            • Assignee:
              Greg Brown
              Reporter:
              Roger Whitcomb
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development