Pivot
  1. Pivot
  2. PIVOT-502

Building with Ant 1.8 gives warnings on the javac tasks

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
    • Environment:
      Windows XP SP3, Sun JDK 1.6.0_16, Apache Ant 1.8.0, using Pivot SVN trunk as of 5/24/10

      Description

      If I do an "ant install" (for instance) there are a series of warnings in the output:
      [javac] C:\Projects\Pivot\svn\trunk\build.xml:127: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
      It would be cleaner if the build.xml set "includeAntRuntime='false'" on all the "javac" tasks to get rid of this warning (or else persuade the Ant project to change this behavior )

        Activity

        Greg Brown added a comment -

        Duplicate of PIVOT-437.

        Sandro Martini added a comment -

        Hi Greg,
        sorry but this is not a duplicate of pivot-437 (that was a blocking error for building pivot with ant-1.8.x), while this is only a set of warnings given from ant-1.8.x during build .

        I'll take a look at this for the 1.6

        Bye,
        Sandro

        Greg Brown added a comment -

        It may make sense to move to Ant 1.8 for Pivot 2.0.


          People

          • Assignee:
            Sandro Martini
            Reporter:
            Roger Whitcomb
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development