Pivot
  1. Pivot
  2. PIVOT-363

Stock Tracker Demo: Inconsistent Selection Behavior when Adding New Ticket Symbol

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.4
    • Component/s: demos
    • Labels:
      None

      Description

      Steps to reproduce:

      1) Run the stock tracker demo
      2) Select GOOG
      3) Add SLV
      4) Add MCO
      5) Sort by Value
      6) Select GOOG
      7) Add FORM

      Expected behavior:

      When you add a new ticker symbol, you expect either (a) the selection to be maintained, (b) the new symbol to be selected, or even (c) the selection to be lost or reset to the first row. B is probably the best user experience.

      Actual behavior:

      The behavior of which row is selected when you add a new symbol differs as you add new symbols in the process above.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        2d 2h 39m 1 Greg Brown 16/Dec/09 14:24
        In Progress In Progress Resolved Resolved
        9m 11s 1 Greg Brown 16/Dec/09 14:33
        Greg Brown made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Greg Brown made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Greg Brown made changes -
        Fix Version/s 1.4 [ 12314166 ]
        Fix Version/s 1.4.1 [ 12314034 ]
        Greg Brown made changes -
        Field Original Value New Value
        Assignee Greg Brown [ gbrown ]
        Greg Brown added a comment -

        The reason this happens is because selection is preserved based on the selected indexes, not the selected symbols. If a symbol's index changes between queries (e.g. when sorting on value and one or more of the stock values change), that selection state will no longer be valid.

        To fix this, we'll need to identify the current index of each selected symbol after re-applying the sort.

        Todd Volkert created issue -

          People

          • Assignee:
            Greg Brown
            Reporter:
            Todd Volkert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development