Details

    • Type: Wish Wish
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3
    • Component/s: project
    • Labels:
      None

      Description

      The Pivot logo is neat, but a bit bland and doesn't mix well with Apache in general.

      1. Pivot Logo (Single Color).svg
        98 kB
        Tay Thien Luh
      2. Pivot Logo (Full Color).svg
        106 kB
        Tay Thien Luh
      3. swiss_knife_final.png
        42 kB
        Tay Thien Luh
      4. teepee.png
        4 kB
        Greg Brown
      5. ui_tool.png
        31 kB
        Tay Thien Luh
      6. swiss_knife.png
        14 kB
        Tay Thien Luh
      7. logo3a.png
        12 kB
        Greg Brown
      8. logo3.png
        12 kB
        Greg Brown
      9. logo2.png
        14 kB
        Greg Brown
      10. logo.png
        13 kB
        Greg Brown
      11. Pivot-14-text2-002.png
        3 kB
        Christopher Brind
      12. Pivot-14-text2-001.png
        3 kB
        Christopher Brind
      13. Pivot-14-device002.png
        0.9 kB
        Christopher Brind
      14. pivot-14-homepage.png
        118 kB
        Christopher Brind
      15. Pivot-14-flat3border.png
        30 kB
        Christopher Brind
      16. Pivot-14-rot1.png
        40 kB
        Christopher Brind
      17. Pivot-14-flat3.png
        31 kB
        Christopher Brind
      18. Pivot-14-device.png
        10 kB
        Christopher Brind
      19. propeller.png
        10 kB
        Greg Brown
      20. pivot_v2_flat.jpg
        53 kB
        Todd Volkert
      21. pivot_logo_flat.gif
        21 kB
        Todd Volkert

        Activity

        Todd Volkert added a comment -

        I've solicited the help of two graphic designer friends of mine, and I'm wondering: do they need to sign a CLA to properly contribute a graphic?

        Niclas Hedhman added a comment -

        Yes and No. If the person submit the work via JIRA, he/she must tick the Contribution Agreement button to upload the work, and that is said to be enough.
        CLA on file is of course better.

        Todd Volkert added a comment -

        Another concept. The author writes "BTW - that's a sketch, I didn't think too much about the detail work, just wanted to give you the idea to see if it was worth working on to see which direction you liked better."

        Todd Volkert added a comment -

        Niclas, I asked the author of these sketches to register with JIRA and add his content directly, but once he registered, he doesn't appear to have permission to comment on this issue. Can you please help? His JIRA login is mreinhardt. Thanks.

        Niclas Hedhman added a comment -

        Well, he belongs to jira-users, and they have rights to comment on issues and create attachments.

        I think he might have forgotten to "Login". Link is on top right corner, next to Printer symbol.

        Greg Brown added a comment -

        I like elements of the graphical part, but I don't like the not-so-subtle P and V characters. I also don't really like the gradients - I had been picturing something a bit simpler. But this is definitely workable. I like the radial look.

        Michael Reinhardt added a comment -

        I don't really like the obvious letters either, I think I glommed too many ideas together with that one. I have one other idea that I will work out and upload later, in addition to reworking the v2 logo. Any ideas for color scheme? I noticed other than Silverlight most of your competitors use red and black. Should I go for something different or similar?

        Christopher Brind added a comment -

        Here's a few ideas I've been playing around with for colour schemes this evening:
        http://kuler.adobe.com/#themeID/432796
        http://kuler.adobe.com/#themeID/432807
        http://kuler.adobe.com/#themeID/432811
        http://kuler.adobe.com/#themeID/432813

        I have to say I liked the radial aspect of v2, but also didn't like the lettering. I think we could just drop the lettering completely from the logo, but might want to agree on an associated style guide for when the name to accompanies the logo, e.g. font, weight, relative size, relative positions, gap between lettering and logo and border around logo when with or without the lettering, etc.

        Sandro Martini added a comment -

        Hi,
        I like both logos, as graphics and as color chosen, but as others said in the v2 logo i don't like letters.

        Maybe for this (v2) we could try to put the Pivot text over the upper part of the circle, in a radial path, but it's difficult to tell is could be good or not before seeing it ...

        In any case, i agree with Christopher also for the Guidelines for the Logo:
        colors, fonts, positions, text visible or not (depending on cases), gradients, etc.

        For the colors maybe other experiments could use the first scheme said by Christopher, or maybe a better choice (more homogeneous with the visual appearance of Pivot) could be to use the same colors from the default skin of that release, so the current colors of Terra now, and the colors of Terra in v2.0 (there is a concept screenshot in JIRA) for the v2 logo ...

        Bye,
        Sandro

        Greg Brown added a comment -

        I just uploaded a (very primitive) concept of a "propeller"-like logo. I'm not a graphic designer, so I know it needs work, but I'm wondering if people think it might be a good starting point.

        Niclas Hedhman added a comment -

        Do you need help with this? I can ask my former staff and see if he is willing and has the time to help out...

        Christopher Brind added a comment -

        Just to re-iterate, I don't think we should have any lettering in there at all.

        I'm afraid I don't like it, Greg... as soon as I saw it I said POP! out loud.

        Though she rarely seems interested enough to do graphics for stuff I want, I'll ask my wife. She's just got her degree (BA) in design...

        Christopher Brind added a comment -

        Here's a few ideas.

        The 'device' is the main thing and we can play around with presentation, as demonstrated by flat3 and rot1.

        My wife came up with the idea of the three blocks pivoting, then I applied some web2.0 magic to it and used colours from the terra palette.

        Thoughts?

        (There is also a version of flat3 with a border to come...)

        Christopher Brind added a comment -

        With border as mentioned above.

        I can reproduce with changes and ultimately Apache license if this is a direction we wish to take.

        Christopher Brind added a comment - - edited

        Btw, the PNGs had a transparent background (i.e. not black) when I created them - uploading them to JIRA must have messed that up, but hopefully you get the idea.

        Edit: looks like the black background is added by JIRA - click on the device image to see it properly.

        Greg Brown added a comment -

        I like the concept. I don't like the vertical one, though - it gives me a sense of instability. Not a good thing for a software platform.

        The horizontal orientation is better, but I think I would prefer more symmetry. What if the blocks were arranged in a straight line, and the one in the middle was slightly larger? Possibly with no fill (like the large central circle in my propeller mock-up)? The red circles would still be used to create the "pivot" points between the blocks.

        Christopher Brind added a comment -

        Greg, just got your comment as I finished the above.

        I'll have a play with what you suggest... my colleague suggests actually getting rid of the gradients as well, so I'll play with that too and post more. Is it OK to just keep attaching images here?

        Christopher Brind added a comment - - edited

        A few more ideas... text2-002 is a little risqué IMHO ... but let me know what you think.

        Can also put container-backgrounds as well if you want to see them.

        edit: damn transparency ... need to click to see them properly.

        edit2 : just in case it's not clear which are new:

        Pivot-14-text-001.png
        Pivot-14-text-002.png
        Pivot-14-device002.png

        Tay Thien Luh added a comment -

        Hi, Niclas wanted me to give this a try, so here are a couple of ideas. Both (ui_tool.png and swiss_knife.png) are based on the idea of "tools behind the interface", not sure if that's even correct now that I've seen the other suggestions, but do comment if it sparks other ideas I can try.

        Regards,
        Thien

        Greg Brown added a comment -

        Hi Thien,

        Sorry for not commenting on this earlier - I wasn't even aware that you had posted those images. They look great!

        I just uploaded a (very primitive) concept that occurred to me last week. The original idea was that the text "pivoted" on top of the triangle, but I realized after mocking it up that it also looks like a teepee, which ties in nicely with the Apache brand.

        The shape of your "Swiss knife" concept is similar - how do you think it would look if we rotated the "knife" part around to point upwards, like the teepee?

        Greg

        Greg Brown added a comment -

        Apparently my wife likes the Swiss knife logo as-is. So maybe my suggestion to rotate it isn't a good one. But what about maybe centering it over the "apachepivot" text? Right now, it looks more right-aligned.

        By the way, the colors and the rest of the overall design look great. Very nice work.

        Christopher Brind added a comment -

        I agree with your wife, Greg

        +1 for the swiss knife logo

        Tay Thien Luh added a comment -

        Logo edited with centralized logotype and revised graphics to make it more 3D. Also included is the exact same logo but in one solid color for other possible uses.

        Niclas Hedhman added a comment -

        I am curious to what happens if the "blade" that comes out is the Apache feather "somehow"...

        Sandro Martini added a comment -

        Hi to all,
        yesterday I copied under project (under trunk) a new folder: /logo , with two logo sources SVG files.

        Then, using Inkscape I used the main logo (the Full Color version of it) to generate some multi-resolution image of both (256x256, 128x128, 64x64, 32x32, 16x16) all PNG with transparent background.
        Then I generated also a logo-notext version of all these images, useful mainly for small icons.
        Finally I've also generated a favicon containing the 64x64, 32x32 and 16x16 images all together.
        But all these files aren't in SVN, because for example with SVG sources we can re-generate them.

        Tell me if at least could be useful to publish them here (and maybe moving existing in a old folder here, to avoid confusion).

        To see some of them, you can synchronize from the trunk, they are in demos/src/www , and are used also as the icon for any our (new) Web Start Demo.

        A great thank you to Tay Thien Luh for its work on Logos, and to others for ideas/suggestions.

        Bye,
        Sandro

        Greg Brown added a comment -

        Since you have already done the work of generating these images, we might as well put them in SVN so others don't need to duplicate the effort. I would suggest putting them in the project/logo directory as well.


          People

          • Assignee:
            Todd Volkert
            Reporter:
            Niclas Hedhman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development