Uploaded image for project: 'Pig'
  1. Pig
  2. PIG-4811

Upgrade groovy library to address MethodClosure vulnerability

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.16.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Please see https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3253
      As Groovy versions 1.7.0 through 2.4.3 are affected by the above CVE, groovy library should be upgraded.

      I'd like to upgrade to the latest version, which is 2.4.5.

        Attachments

        1. PIG-4811.patch
          0.4 kB
          Jianyong Dai

          Activity

            People

            • Assignee:
              daijy Jianyong Dai
              Reporter:
              daijy Jianyong Dai
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: