Uploaded image for project: 'Pig'
  1. Pig
  2. PIG-4535

Pig 0.14.0 with HBase 1.0.0(upgraded dependecy) unresolved dependency error for required hbase jars

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.17.0
    • Component/s: build
    • Labels:
      None

      Description

      When upgraded HBase dependency to version HBase 1.0.0 in ivy/libraries.xml, we get unresolved dependency errors for hbase jars.
      [ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
      [ivy:resolve] :: UNRESOLVED DEPENDENCIES ::
      [ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
      [ivy:resolve] :: org.apache.hbase#hbase-client;1.0.0-hadoop2: not found
      [ivy:resolve] :: org.apache.hbase#hbase-common;1.0.0-hadoop2: not found
      [ivy:resolve] :: org.apache.hbase#hbase-server;1.0.0-hadoop2: not found
      [ivy:resolve] :: org.apache.hbase#hbase-protocol;1.0.0-hadoop2: not found
      [ivy:resolve] :: org.apache.hbase#hbase-hadoop-compat;1.0.0-hadoop2: not found
      [ivy:resolve] :: org.apache.hbase#hbase-hadoop2-compat;1.0.0-hadoop2: not found
      [ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::

        Attachments

        1. PIG-4535.patch
          0.5 kB
          Swati

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                Swati Swati
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: