Uploaded image for project: 'Pig'
  1. Pig
  2. PIG-4185

ivy\lib\Pig\junit-4.11.jar; invalid CEN header

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 0.13.0
    • Fix Version/s: None
    • Component/s: build
    • Labels:
      None
    • Environment:

      Windows 7

      Description

      In either trunk or branch-0.13 I run ant -Dhadoopversion=23.
      Problem seems to be in junit-4.11.jar.
      Not sure from where pig or ivy is pulling this corrupt file.
      Work around is to copy junit-4.11.jar from maven repo, but this solution doesn't lend itself to automated builds.
      Get:
      compile:
      [echo] *** Building Main Sources ***
      [echo] *** To compile with all warnings enabled, supply -Dall.warnings=1 on command line ***
      [echo] *** Else, you will only be warned about deprecations ***
      [javac] Compiling 5 source files to C:\pig\branches\branch-0.13\build\classes
      [javac] error: error reading C:\pig\branches\branch-0.13\build\ivy\lib\Pig\junit-4.11.jar; invalid CEN header (bad signature)
      [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.5
      [javac] 1 error
      [javac] 1 warning
      Buildfile: C:\pig\branches\branch-0.13\contrib\piggybank\java\build.xml

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ddreyfus David Dreyfus
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: