Pig
  1. Pig
  2. PIG-3639

TestRegisteredJarVisibility is broken in trunk

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.13.0
    • Component/s: None
    • Labels:
      None

      Description

          [junit] Running org.apache.pig.test.TestRegisteredJarVisibility
          [junit] Tests run: 3, Failures: 1, Errors: 0, Time elapsed: 44.127 sec
          [junit] Test org.apache.pig.test.TestRegisteredJarVisibility FAILED
      

      This is a side-effect of PIG-3584 that bumped avro version to 1.7.5.

      The problem is that avro 1.7.5 pulls down jackson 1.9.9 jars as dependencies, and that makes TestRegisteredJarVisibility.testRegisterJarOverridePigJarPackages fail because the test case assumes that jackson 1.9.9 jars are not present in classpath.

      1. PIG-3639-1.patch
        1 kB
        Cheolsoo Park

        Activity

        Cheolsoo Park created issue -
        Cheolsoo Park made changes -
        Field Original Value New Value
        Description {code}
            [junit] Running org.apache.pig.test.TestRegisteredJarVisibility
            [junit] Tests run: 3, Failures: 1, Errors: 0, Time elapsed: 44.127 sec
            [junit] Test org.apache.pig.test.TestRegisteredJarVisibility FAILED
        {code}
        This is a side-effect of PIG-3584 that bumped avro version to 1.7.5.

        The problem is that avro 1.7.5 pulls jackson 1.9.9 jars as dependencies, and that makes TestRegisteredJarVisibility.testRegisterJarOverridePigJarPackages because the test case assumes that jackson 1.9.9 jars are not present in classpath.
        {code}
            [junit] Running org.apache.pig.test.TestRegisteredJarVisibility
            [junit] Tests run: 3, Failures: 1, Errors: 0, Time elapsed: 44.127 sec
            [junit] Test org.apache.pig.test.TestRegisteredJarVisibility FAILED
        {code}
        This is a side-effect of PIG-3584 that bumped avro version to 1.7.5.

        The problem is that avro 1.7.5 pulls down jackson 1.9.9 jars as dependencies, and that makes TestRegisteredJarVisibility.testRegisterJarOverridePigJarPackages fail because the test case assumes that jackson 1.9.9 jars are not present in classpath.
        Cheolsoo Park added a comment -

        The patch excludes the jackson jars from avro dependencies.

        I confirmed TestRegisteredJarVisibility and TestAvroStorage both pass.

        Cheolsoo Park made changes -
        Attachment PIG-3639-1.patch [ 12620060 ]
        Cheolsoo Park made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Jarek Jarcec Cecho added a comment -

        Thank you for filling the JIRA and providing patch Cheolsoo Park! I was experiencing the same failure in our environment when upgraded Avro to version 1.7.5. Sadly I did not had time to investigate it myself.

        +1 (non-binding)

        Rohini Palaniswamy added a comment -

        +1

        Cheolsoo Park added a comment -

        Committed to trunk. Thank you Jarcec and Rohini for the review!

        Cheolsoo Park made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Daniel Dai made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        5m 23s 1 Cheolsoo Park 21/Dec/13 23:38
        Patch Available Patch Available Resolved Resolved
        5d 22h 39m 1 Cheolsoo Park 27/Dec/13 22:17
        Resolved Resolved Closed Closed
        191d 19h 50m 1 Daniel Dai 07/Jul/14 19:07

          People

          • Assignee:
            Cheolsoo Park
            Reporter:
            Cheolsoo Park
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development