Uploaded image for project: 'Pig'
  1. Pig
  2. PIG-3520

Provide backward compatibility for PigRunner and PPNL after PIG-3419

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.13.0
    • Component/s: impl
    • Labels:
      None

      Description

      PIG-3419 did backend refactory to support multiple backend. However, it break backward compatibility of two widely used API: PigRunner and PPNL. And it does not provide a deprecate path.

        Attachments

        1. PIG-3520-1.patch
          10 kB
          Daniel Dai

          Issue Links

            Activity

              People

              • Assignee:
                daijy Daniel Dai
                Reporter:
                daijy Daniel Dai
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: