Pig
  1. Pig
  2. PIG-2793 Make Pig Work on Windows without Cygwin
  3. PIG-3291

TestExampleGenerator fails on Windows because of lack of file name escaping

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.12.0
    • Fix Version/s: 0.12.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows

    • Hadoop Flags:
      Reviewed

      Description

      On Windows, all tests fail with an exception like this:
      Testcase: testFilterGroupCountStore took 0.022 sec
      Caused an ERROR
      Error during parsing. <line 1, column 228> Unexpected character 'S'
      org.apache.pig.impl.logicalLayer.FrontendException: ERROR 1000: Error during parsing. <line 1, column 228> Unexpected character 'S'
      at org.apache.pig.PigServer$Graph.parseQuery(PigServer.java:1669)
      at org.apache.pig.PigServer$Graph.registerQuery(PigServer.java:1607)
      at org.apache.pig.PigServer.registerQuery(PigServer.java:563)
      at org.apache.pig.PigServer.registerQuery(PigServer.java:576)
      at org.apache.pig.test.TestExampleGenerator.testFilterGroupCountStore(TestExampleGenerator.java:394)
      Caused by: Failed to parse: <line 1, column 228> Unexpected character 'S'
      at org.apache.pig.parser.QueryParserDriver.parse(QueryParserDriver.java:235)
      at org.apache.pig.parser.QueryParserDriver.parse(QueryParserDriver.java:174)
      at org.apache.pig.PigServer$Graph.parseQuery(PigServer.java:1660)

      Looks like a change in https://issues.apache.org/jira/browse/PIG-2170 caused the file names to stop being escaped properly.

      1. PIG-3291.trunk.patch
        1 kB
        David Wannemacher

        Activity

        David Wannemacher created issue -
        David Wannemacher added a comment -

        Fixes the problem on windows and tested on linux

        David Wannemacher made changes -
        Field Original Value New Value
        Attachment PIG-3291.trunk.patch [ 12580103 ]
        David Wannemacher made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        David Wannemacher made changes -
        Parent PIG-2793 [ 12597859 ]
        Issue Type Bug [ 1 ] Sub-task [ 7 ]
        Daniel Dai made changes -
        Assignee David Wannemacher [ dwann ]
        Daniel Dai added a comment -

        +1. Patch committed to trunk. Thanks David!

        Daniel Dai made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Resolution Fixed [ 1 ]
        Daniel Dai made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        3m 9s 1 David Wannemacher 23/Apr/13 20:10
        Patch Available Patch Available Resolved Resolved
        20d 23h 4m 1 Daniel Dai 14/May/13 19:15
        Resolved Resolved Closed Closed
        152d 22h 31m 1 Daniel Dai 14/Oct/13 17:46

          People

          • Assignee:
            David Wannemacher
            Reporter:
            David Wannemacher
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development