Pig
  1. Pig
  2. PIG-1640

bin/pig does not run in local mode due to classes missing from classpath

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0
    • Component/s: None
    • Labels:
      None

      Description

      This issue was reported by one of Yahoo users. I have not verified the problem. Here is the report

      "when do bin/pig -x local, the shell doesn't come up. It complained about jline not being found. Here is a patch to bin/pig:

      +for f in $PIG_HOME/build/ivy/lib/Pig/*.jar; do
      + CLASSPATH=$

      {CLASSPATH}

      :$f;
      +done
      +"

        Activity

        Olga Natkovich added a comment -

        I looked into this issue and was able to reproduce the behavior. The problem is that we are bundling and using wrong pig.jar. I will be fixing that as part of the release process


          People

          • Assignee:
            Olga Natkovich
            Reporter:
            Olga Natkovich
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development