Pig
  1. Pig
  2. PIG-1282

[zebra] make Zebra's pig test cases run on real cluster

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6.0
    • Fix Version/s: 0.7.0
    • Component/s: None
    • Labels:
      None

      Description

      The goal of this task is to make Zebra's pig test cases run on real cluster.

      Currently Zebra's pig test cases are mostly tested using MiniCluster. We want to use a real hadoop cluster to test them.

      1. PIG-1282.patch
        606 kB
        Chao Wang

        Activity

        Yan Zhou added a comment -

        patch committed to the trunk.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12439427/PIG-1282.patch
        against trunk revision 925868.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 254 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/261/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/261/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/261/console

        This message is automatically generated.

        Chao Wang added a comment -

        added hadoop license comment to BaseTestCase.java

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12439224/PIG-1282.patch
        against trunk revision 925513.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 254 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        -1 release audit. The applied patch generated 523 release audit warnings (more than the trunk's current 522 warnings).

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/257/testReport/
        Release audit warnings: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/257/artifact/trunk/patchprocess/releaseAuditDiffWarnings.txt
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/257/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/257/console

        This message is automatically generated.

        Xuefu Zhang added a comment -

        +1

        Chao Wang added a comment -

        The new attached patch addressed the concerns raised by Xuefu Zhang.

        All pig and map/reduce test cases get significantly polished.

        The major changes include: (Please see pig/TestBasicTableUnionLoader for example)

        1) all test case extend BaseTestCase, call init() within setup();

        2) use getTableFullPath() utility function

        3) use removeDir() utility function

        This task involves lots of mechanical work and many thanks to Jax Law, Xuefu Zhang, Gaurav Jain and Yan Zhou for sharing the load.

        Xuefu Zhang added a comment -

        +1, though two repeated patterns that can be better organized. 1. removeDir() appears in many test cases. Ideally, this can be made as a method of some utility class. 2. Same logic of determine running mode (realCluster, miniCluster, MapReduce/Local) appears in most of these test cases. Ideally, this should be made as configurations instead of a bunch of if ... else... statements. Hopefully, these two issue can be addressed in the near future.

        Chao Wang added a comment -

        The test case failure is caused by some environmental issue.

        I reran the failed test case manually and it was successful.

        org.apache.pig.test.TestSecondarySort

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12438433/PIG-1282.patch
        against trunk revision 921483.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 270 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/240/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/240/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/240/console

        This message is automatically generated.

        Chao Wang added a comment -

        Thank Jing for the most of the migration work.


          People

          • Assignee:
            Chao Wang
            Reporter:
            Chao Wang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development