Pig
  1. Pig
  2. PIG-1133

UDFContext should be made available to LoadFunc.bindTo

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.4.0
    • Fix Version/s: 0.6.0
    • Component/s: impl
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Currently UDFContext is available at frontend, map and reduce. However, LoadFunc.bindTo will be called on InputFormat.getSplits, which is on a different context then the ones mentioned before. UDFContext should be available in that context as well.

        Activity

        Daniel Dai added a comment -

        This issue is not reproducible in either hadoop local mode and MiniCluster. So it is meaningless to include a unit test. I test it manually on a real cluster.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12427280/PIG-1133-1.patch
        against trunk revision 888186.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/103/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/103/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Console output: http://hudson.zones.apache.org/hudson/job/Pig-Patch-h8.grid.sp2.yahoo.net/103/console

        This message is automatically generated.

        Alan Gates added a comment -

        Changes look good. It might be good to change the unit tests in TestUDFContext to test that the conf is available in the bindTo.

        Daniel Dai added a comment -

        The interesting thing is UDFContext is always available to SliceWrapper in MiniCluster and local mode. Only in real cluster, we cannot get correct UDFContext setup. I guess MiniCluster and real cluster use different context when invoking SliceWrapper. That's why I do not put unit test because none unit test can simulate the real cluster situation.

        Alan Gates added a comment -

        Yeah, I missed your first comment before I asked that question. Ok, no test seems fine then.

        Daniel Dai added a comment -

        Patch committed to both trunk and 0.6 branch.


          People

          • Assignee:
            Daniel Dai
            Reporter:
            Daniel Dai
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development